1. 1.试图运行程序,提示"libc.so.6: version `GLIBC_2.14’ not found”,原因是系统的glibc版本太低,软件编译时使用了较高版本的glibc引起的

  2. 查看系统glibc支持的版本

  3. 可以看到最高只支持2.12版本,所以考虑编译解决这个问题:

    1. 官网下载最新版本
    2. 在glibc源码目录建立构建目录,并cd进入构建目录:mkdir build&&cd build
    3. 配置:../configure --prefix=/opt/glibc-2.14
    4. 安装:make&&make install
    5. 临时导入变量:export LD_LIBRARY_PATH=/usr/local/glibc/lib:$LD_LIBRARY_PATH

参考:解决libc.so.6: version `GLIBC_2.14’ not found问题