如图:

问题出现原因:

yum包管理是使用python2.x写的,将python2.x升级到python3.1.3以后,由于python版本语法兼容性导致问题出现 解决办法: 修改yum配置文件,将python版本指向以前的旧版本

  1. vim /usr/bin/yum
  2. #!/usr/bin/python2.7
  3. vim /usr/libexec/urlgrabber-ext-down
  4. #!/usr/bin/python2.7